TrailManor Owner's Forum  

Go Back   TrailManor Owner's Forum > TrailManor Technical Discussions > Electrical
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-14-2024, 11:27 AM   #1
Theodore Arsovski
New Member
 
Join Date: Oct 2023
Posts: 4
Default Water pump and switch not workin

Hi,

The water pump switch doesn’t turn bright when switched to ON position and the pump doesn’t work either. The other switches on the panel work fine (heater, fridge fan, and system check).

I will appreciate if you have any tips for me on what might be causing this and how to fix it? I have a 2720 from 2008.

Thanks in advance!
Theodore
Theodore Arsovski is offline   Reply With Quote
Old 04-14-2024, 02:11 PM   #2
Bill
Site Team
 
Bill's Avatar
 
Join Date: Feb 2003
Location: The mountains of Scottsdale, AZ, and the beaches of Maine
Posts: 10,112
Default

The water pump switch has a pilot light? I guess I had forgotten. There are different switch arrangements used, and my TM is closed up in the garage so I can't check it.

Don't forget that the water pump turns on only when the water pressure in the system is low. In other words, when it needs to pump. As soon as the pressure comes up to normal (40 psi or so), the pump shuts off

Bill
__________________
2020 2720QS (aka 2720SL)
2014 Ford F-150 4WD 5.0L
Bill's Tech Stuff album
Bill is offline   Reply With Quote
Old 04-14-2024, 09:30 PM   #3
Kidkraz
Site Sponsor
 
Kidkraz's Avatar
 
Join Date: Mar 2013
Posts: 1,048
Default

With the switch in the on position and you open any tap, does the pump run or make any indication of running? Have you checked the fuse? You may have a bad pump or fuse.
__________________
2013 2619
80 watt solar panel/swing hitch/low profile A/C.
Enduro 4445 caravan mover
2016 Dodge Ram 1500 V8 Hemi
Installed powered folding tow mirrors

Stopped playing with airplanes, now I just enjoy watching them fly by.
Kidkraz is online now   Reply With Quote
Old 04-15-2024, 09:57 AM   #4
Bill
Site Team
 
Bill's Avatar
 
Join Date: Feb 2003
Location: The mountains of Scottsdale, AZ, and the beaches of Maine
Posts: 10,112
Default

Unless a previous owner has replaced it, I believe you have a Shur-Flo 4008 RV Revolution pump. The standard switch that comes with that unit has two electrical connections on the back of it, one coming from the 12 VDC supply, the other going to the pump. In order for the switch to have a pilot light, it would need 3 connections, with the third one providing a ground connection for the light. If you don't have a third connection, there is no light.

Can you stick your head into the cabinet and look at the back of the switch? Are there two wires or three connected to the switch? A photo would help.

Bill
__________________
2020 2720QS (aka 2720SL)
2014 Ford F-150 4WD 5.0L
Bill's Tech Stuff album
Bill is offline   Reply With Quote
Old 04-20-2024, 05:42 PM   #5
Theodore Arsovski
New Member
 
Join Date: Oct 2023
Posts: 4
Default

Hi Bill and Kidkraz,

Thanks to your advice I was able to fix the issue. It was both an issue with the ground connection and a blown fuse. I fixed both and the pump works well again!

Many thanks!
Theodore
Theodore Arsovski is offline   Reply With Quote
Old 04-20-2024, 09:32 PM   #6
Kidkraz
Site Sponsor
 
Kidkraz's Avatar
 
Join Date: Mar 2013
Posts: 1,048
Default

Glad you found the problems and in letting the forum know.
__________________
2013 2619
80 watt solar panel/swing hitch/low profile A/C.
Enduro 4445 caravan mover
2016 Dodge Ram 1500 V8 Hemi
Installed powered folding tow mirrors

Stopped playing with airplanes, now I just enjoy watching them fly by.
Kidkraz is online now   Reply With Quote
Reply

Tags
broken, light, panel, pump, switch


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Water Heater PeterOC Appliances 5 04-08-2016 10:15 PM
Hot water heater purge issue MarkoPolo Appliances 11 04-21-2013 10:39 PM
SOLUTION: The ultimate fresh water transfer pump ShrimpBurrito Plumbing 38 03-01-2012 03:40 PM
Water pump not pumping water ShrimpBurrito Plumbing 17 03-28-2011 03:00 PM
Water pump doesn't turn on - bad pressure switch? ShrimpBurrito Plumbing 11 09-02-2009 03:19 PM


All times are GMT -6. The time now is 10:30 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright 2022 Trailmanor Owners Page.