TrailManor Owner's Forum  

Go Back   TrailManor Owner's Forum > TrailManor General Discussions > General discussion
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 05-23-2018, 11:58 AM
Tomahawk Tomahawk is offline
Site Sponsor
 
Join Date: Oct 2017
Posts: 3
Default A/C replacement unit issue and recs needed

I have a 2009 2720 that we purchased in Oct 2017 and the AC worked fine during inspection. Our first time using it in April this year and it starts up then after a couple of minutes it kicks up and cool. Then another couple a minutes a big whomp sound and the AC stops but the fan keeps running. Replaced capacitor but same problem. Any other suggestions? Also, is replacing an AC unit something we should have outsourced or was it a pretty easy swap out? Hubby is an electrical engineer so has skills but he's wondering if it's a pain and worth paying someone to do. Also, what is best recommendation for replacement? I see AtwoodAir Command mentioned. Thank you!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:15 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2011 Trailmanor Owners Page.