TrailManor Owner's Forum  

Go Back   TrailManor Owner's Forum > TrailManor Elkmont > General Discussion
Register FAQ Members List Calendar Mark Forums Read

 
 
Thread Tools Display Modes
  #1  
Old 08-29-2012, 02:37 PM
brulaz
Guest
 
Posts: n/a
Default Elkmont Kitchen Faucet and Frig-Propane problems

Thought I'd document these two problems here as I know the Elkmont frig is different from other Trailmanors and perhaps the kitchen faucet is (?).

First the weird kitchen faucet problem: filled up the water tank, turned on the pump and the kitchen faucet would not turn off, hot or cold. Popped the handles and noticed that pressing down on the valve stems would stop the flow. Turns out there's an O-ring on the bottom through which the water flows and the stem has to be compressed against this or the water's on all the time.

There's an outer nut that forces the stem down, but it couldn't be tightened any further. Hmmmm. Removed the metal decorative base of the faucet, and now the nut could be tightened and water flow stopped. Turns out the bottom inside of the decorative base had corroded enough to lift it up and interfere with the tightening of the stem nuts. IOW the decorative base was too tall. A file and some sandpapering off the base fixed the problem.


The frig on propane problem: it wouldn't light. Opened it up, and it looked like there was some flame in there, but not enough? Took off the little metal box around the base of the burner and, yes, there was gas and flame but not where it should be.

The gas line comes into a horizontal burner assembly. The bigger 5/8" nut holds the gas line to the burner assembly, and then there is another 1/2" nut on the end of the assembly (that you do NOT want to move relative to the rest of the assembly). I found the space too tight to get any wrenches in there anyway. The burner assembly beyond the 1/2" nut is just a tube. First are three air holes through which you can see the gas nozzle. The air-gas mix then travels further to several slots on the top of the tube, where it should exit and be ignited.

Typically the gas nozzle would be plugged. But in this case the gas got past the nozzle but somehow could not get further to the slots. Instead, there was a flame above the 3 air holes! Luckily the flame sensor turned everything off after a short while.

As I couldn't figure how to get the whole burner assembly out, I first vacuumed the area and noticed a lot of rusty looking metal flakes. Then I used the compressor to blow air into one of the 3 air holes (blocking the others) and back toward the slots (and away from the gas nozzle). I also tried to blow air into the slots, which blew out a fair amount of metal flakes. After doing this many times, the frig eventually started working on propane again. Think the rusty flakes came from above in the chimney somewhere.

No idea if I got all the garbage out of the burner assembly, but I suspect this may be an ongoing issue, so am adding this to the annual maintenance list. At some point it may be necessary to take it in and have a pro look at it.
  #2  
Old 09-04-2012, 07:44 PM
Redhawk
Guest
 
Posts: n/a
Default

Your posts are much appreciated Bruce...I'm sure this will help me and others down the road. Hopefully WAY down the road. LOL Thanks!
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Copyright 2011 Trailmanor Owners Page.